Skip to main content
Viptela is now part of Cisco.
Support
Product Documentation
Viptela Documentation

show running-config

show running-config—Display the active configuration that is running on the Viptela device. Use the details filter with this command to display the default values for configured components.

Command Syntax

show running-config [configuration-hierarchy]
show running-config [configuration-hierarchy] | details

Options

None
Display the full active configuration.
Default Values in Running Configuration
| details
Display the default values for the components configured in the running configuration.
Specific Configuration Hierarchy
configuration-hierarchy
Display the active configuration for a specific hierarchy in the configuration.

Output Fields

The output fields are self-explanatory.

Note that the default BFD configuration is not displayed when you issue the show running-config command on vEdge router. This is because BFD is always enabled on these routers so that the data plane in the overlay network is operational, and there is no shutdown configuration command to disable it. However, if you configure additional BFD properties, they are displayed by the show running-config command.

Example Output

vEdge# show running-config system
system
host-name vedge1
system-ip 172.16.255.1
domain-id 1
site-id   1
clock timezone America/Los_Angeles
vbond 10.0.14.4
aaa
  auth-order local radius
  usergroup basic
   task system read write
   task interface read write
  !
  usergroup netadmin
  !
  usergroup operator
   task system read
   task interface read
   task policy read
   task routing read
   task security read
  !
  user admin
   password $1$zvOh58pk$QLX7/RS/F0c6ar94.xl2k.
  !
  user eve
   password $1$aLEJ6jve$aBpPQpkl3h.SvA2dt4/6E/
   group    operator
  !
!
logging
  disk
   enable
  !
 !
!
vEdge# show running-config vpn 1 
vpn 1
 name ospf_and_bgp_configs
 router
  ospf
   router-id 172.16.255.15
   timers spf 200 1000 10000
   redistribute static
   redistribute omp
   area 0
    interface ge0/4
    exit
   exit
  !
  pim
   interface ge0/5
   exit
  exit
 !
 interface ge0/4
  ip address 10.20.24.15/24
  no shutdown
 !
 interface ge0/5
  ip address 56.0.1.15/24
  no shutdown
 !
!
vEdge# show running-config vpn 1 | details 
vpn 1
 name ospf_and_bgp_configs
 no ecmp-hash-key layer4
 router
  ospf
   router-id 172.16.255.15
   auto-cost reference-bandwidth 100
   compatible rfc1583
   distance external 0
   distance inter-area 0
   distance intra-area 0
   timers spf 200 1000 10000
   redistribute static
   redistribute omp
   area 0
    interface ge0/4
     hello-interval      10
     dead-interval       40
     retransmit-interval 5
     priority            1
     network             broadcast
    exit
   exit
  !
  pim
   no shutdown
   no auto-rp
   interface ge0/5
    hello-interval      30
    join-prune-interval 60
   exit
  exit
 !
 interface ge0/4
  ip address 10.20.24.15/24
  flow-control        autoneg
  no clear-dont-fragment
  no pmtu
  mtu                 1500
  no shutdown
  arp-timeout         1200
 !
 interface ge0/5
  ip address 56.0.1.15/24
  flow-control        autoneg
  no clear-dont-fragment
  no pmtu
  mtu                 1500
  no shutdown
  arp-timeout         1200
 !
!

Release Information

Command introduced in Viptela Software Release 14.1.

Additional Information

config

  • Was this article helpful?